Главная > О 4Site CMS > Технические требования

Технические требования 4Site CMS

Сервер Apache Nginx HTML5 Percona Server Система управления базами данных (СУБД) MySQL Полнотекстовый поиск Sphinx Дистрибутив Linux Ubuntu Технология mod_perl Язык Perl Tarantool

Мы рекомендуем использовать систему на выделенном сервере или VPS-хостинге c root-доступом. В этом случае можно установить все требуемое программное обеспечение.

Для работы 4Site на сервере потребуется следующий набор ПО.

  • ОС Linux (мы советуем Ubuntu)
  • Интерпретатор языка Perl версии 5.10+
  • СУБД MySQL версии 5.5+ (также можно использовать MariaDB, Percona Server)
  • Веб-сервер Nginx
  • Веб-сервер Apache версии 2.0+
  • Модуль mod_perl версии 2.0+
  • Набор модулей CPAN (определяется требуемой функциональностью)
  • Поисковая система Sphinx
  • Различные утилиты для модуля оптимизации (optiPNG, jpegoptim, cwebp, zopfli)

Большинство указанного программного обеспечения доступно в виде пакетов для быстрой установки в популярных Linux-дистрибутивах.

Заказать разработку
Ваше имя
Ваш e-mail
Телефон
Содержание